Wise Payments - Global transfers

Incident Report for Webexpenses

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 14:18 GMT

Monitoring

A fix has been implemented and Wise are monitoring the results.
Posted Mar 25, 2025 - 14:17 GMT

Investigating

Wise have informed us that they are currently experiencing an issue affecting global transfers. Their team is working to fix this as soon as possible.
Posted Mar 25, 2025 - 13:10 GMT
This incident affected: EMEA + NALA (Payments).